Error in SonarLint for IntelliJ after updating to latest plugin version

  • Java: OpenJDK 64-Bit Server VM by JetBrains s.r.o. 17.0.10+1-b1087.17 amd64
  • OS: Windows 10 amd64
  • IDE: IntelliJ IDEA 2023.3.4 (Ultimate Edition)
  • SonarLint:

I get the following exception on every analysis SonarLint tries to do, so I can’t use the plugin anymore:

Internal error: java.nio.charset.UnsupportedCharsetException: NATIVE_TO_ASCII_ISO-8859-1
Error running SonarLint analysis
java.util.concurrent.CompletionException: org.eclipse.lsp4j.jsonrpc.ResponseErrorException: Internal error.
	at java.base/java.util.concurrent.CompletableFuture.encodeThrowable(
	at java.base/java.util.concurrent.CompletableFuture.completeThrowable(
	at java.base/java.util.concurrent.CompletableFuture$UniAccept.tryFire(
	at java.base/java.util.concurrent.CompletableFuture.postComplete(
	at java.base/java.util.concurrent.CompletableFuture.completeExceptionally(
	at org.eclipse.lsp4j.jsonrpc.RemoteEndpoint.handleResponse(
	at org.eclipse.lsp4j.jsonrpc.RemoteEndpoint.consume(
	at org.sonarsource.sonarlint.core.rpc.protocol.SingleThreadedMessageConsumer.lambda$new$0(
	at java.base/java.util.concurrent.Executors$
	at java.base/
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
	at java.base/java.util.concurrent.ThreadPoolExecutor$
	at java.base/
Caused by: org.eclipse.lsp4j.jsonrpc.ResponseErrorException: Internal error.
	... 8 more

Thank you very much in advance!

Same issue. This also blocks commits via pre-commit check integration.

Hello guys,

Thanks for reporting, and sorry for the problem you are facing.

Are there any other details you could share with us? Is the stack trace you shared above complete? Do you see anything in the logs?

We would be eager to fix those problems as soon as possible.

In the meantime, you can downgrade to the 10.3

Hi Damien,

thanks for your quick reply!

The stack trace is complete, I had the verbose logging enabled. I don’t know what else I could provide.

I tried to reproduce the error now and it’s suddenly different:
The error sometimes appears in IntelliJ and the idea.log, but the stack trace is no longer printed to the SonarLint log tab. But the message Internal error: java.nio.charset.UnsupportedCharsetException: NATIVE_TO_ASCII_ISO-8859-1 appears quite frequently. But analysis works all of a sudden?!


For people encountering this problem, we made a custom build that should fix the problem. Could somebody in this thread install it and verify the fix works? This will help us prepare the bugfix release. Thank you


I had the same issue, tested with the custom build and it works with the fix

1 Like

Thank you very much Damien, looks good here as well!

I installed the custom build and still get the message “SonarLint service encountered an issue and stopped working”.

Do you see something useful in the verbose logs?

FYI we have fixes on the way that should be released today or tomorrow

Only a batch error saying that the jre call is syntactically incorrect at this place in the batch file.

I can confirm that the plugin V10.4.1.77998 works.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.