Error in SonarLint for IntelliJ 2023.3

Environment:

  • Java: JetBrains s.r.o. 17.0.9
  • OS: Windows 11 amd64
  • IDE: IntelliJ IDEA 2023.3
  • SonarLint: 8.5.0.75082
c.ij.oa.diagnostic.RuntimeExceptionWithAttachments: Read access is allowed from inside read-action (see Application.runReadAction()); see https://jb.gg/ij-platform-threading for details
Current thread: Thread[AWT-EventQueue-0,6,main] 767471260 (EventQueue.isDispatchThread()=true)
SystemEventQueueThread: (same)
	at c.ij.util.concurrency.ThreadingAssertions.createThreadAccessException(ThreadingAssertions.java:149)
	at c.ij.util.concurrency.ThreadingAssertions.softAssertReadAccess(ThreadingAssertions.java:107)
	at c.ij.oa.application.impl.ApplicationImpl.assertReadAccessAllowed(ApplicationImpl.java:1012)
	at c.ij.oa.fileEditor.impl.FileDocumentManagerBase.getDocument(FileDocumentManagerBase.java:47)
	at c.ij.oa.editor.impl.RangeMarkerImpl.getDocument(RangeMarkerImpl.java:138)
	at c.ij.oa.editor.impl.RangeMarkerImpl.getDocument(RangeMarkerImpl.java:25)
	at o.sl.ij.ui.nodes.IssueNode.issueCoordinates(IssueNode.java:120)
	at o.sl.ij.ui.nodes.IssueNode.render(IssueNode.java:73)
	at o.sl.ij.ui.tree.TreeCellRenderer.customizeCellRenderer(TreeCellRenderer.java:37)
	at c.ij.ui.ColoredTreeCellRenderer.rendererComponentInner(ColoredTreeCellRenderer.java:125)
	at c.ij.ui.ColoredTreeCellRenderer.getTreeCellRendererComponent(ColoredTreeCellRenderer.java:57)
	at c.ij.ui.tree.ui.DefaultTreeUI.getRenderer(DefaultTreeUI.java:191)
	at c.ij.ui.tree.ui.DefaultTreeUI.paint(DefaultTreeUI.java:331)
	at java.desktop/javax.swing.plaf.ComponentUI.update(ComponentUI.java:161)

Hey there.

The latest version of SonarLint for IntelliJ is v10.1 – can you upgrade and see if the issue persists?

no I can’t. Each time I want to upgrade the SonarLint plugin, I run into an http timeout error

image

And it was never different in the recent months. I’m so used to it that I even don’t recognize when this happens again.

I’m not sure why that’s happening. Can you try manually downloading/installing the latest version?

yeah, that has worked out. Many thanks!