Elasticsearch indices error

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
  • Enterprise Edition Version 9.9.3
  • how is SonarQube deployed: zip, Docker, Helm
  • what are you trying to achieve
    I use maven sonar plugin and ant sonar plugin, in both cases I get this error
    Elasticsearch indices have become inconsistent. Consider re-indexing. Check documentation for more information [Troubleshooting](https://docs.sonarsource.com/sonarqube/latest/setup-and-upgrade/troubleshooting/)
  • what have you tried so far to achieve this
    restarted the server, restarted the container, removed custom quality profiles. The issue is not related to disk size, we have plenty of free space.
    Do not share screenshots of logs – share the text itself (bonus points for being well-formatted)!

Have you followed the instructions here?


  1. Stop SonarQube
  2. Delete the data/es8 directory
  3. Restart SonarQube

Yes, we have tried that. Sonar is running in a docker container, we stopped/restarted everything and even rebuilt the container. Moreover, we just rebuilt everything from scratch (sonar server and database), but for some reason my first try to push analysis results ended with same error.


What do the logs say?

The logs were first thing to check. However, I don’t see any clear Elasticsearch errors or warnings. We used to have Sonar Community edition, that worked perfectly. Then we switched to Enterprise solution to have more features available, but the setup for both is identical except the database. For the CE we used postgreSQL, but for the EE we decided to use MySQL. Could this be potentially a reason of the issue?

MySQL is not a supported database platform any longer (and hasn’t been for years). Are you sure it’s MySQL?

It shouldn’t be the reason, but now I’m a bit suspicious.

Sorry Colin, it is Microsoft SQL Server.


I’m not sure what’s going on.

Is the project that’s having trouble during analysis using some custom Quality Profiles (not the default Sonar Way)?

No, we are not using any custom Quality Profiles. It’s totally default at the moment.