ElasticSearch error

We are trying to install sonarqube enterprise version on redhat linux.

But we keep on getting below error

[1] bootstrap checks failed
[1]: max file descriptors [4096] for elasticsearch process is too low, increase to at least [65535]

I tried multiple solution, but nothing seems to work example : vm.max_map_count=262144 in /etc/sysctl.conf

Also tried to change setting in elasticsearch.yml.

Is there anyway to bypass bootstrap check setting.


There’s no way to bypass the bootstrap checks. You’ll just have to figure out why your settings aren’t kicking in.