Eclipse marketplace sonar lint plugin 9.1?


I installed the sonarlint plugin in eclipse 2023-09.

The marketplace app shows SonarLint 9.1 is installed …

… but the version showing in the Installed Software list is showing 7.,13.0.80073.

I have tried uninstalling & reinstalling the plug-in, even going as far as erasing the plugin artifacts after uninstalling.

It looks like the update site being used is:

Is there a different plug-in repository to use to get version 9.1?

  • Operating system: KDE Neon Linux / Ubuntu
  • SonarLint plugin version: not sure
  • Programming language you’re coding in: n/a
  • Is connected mode used:n/a



Hi @fallingrock

We have changed the minimal VM requirement to Java 17 for the recent SonarLint releases.
It means your Eclipse IDE should run itself with Java 17+ to install SonarLint.

This is normally the case for Eclipse 2023-09 if you take the installation packages that are bundled with a JRE. You can check what is the JRE used by your Eclipse in Help → About → Installation Details → Configuration

To manually change the VM used to start Eclipse, see eclipse.ini - Eclipsepedia

Note that starting Eclipse with a recent JRE (17 or even 21) doesn’t prevent you to work on Java projects targeting older Java versions. And same for SonarLint: our code is (soon to be) compiled for Java 17, but we can still analyze and report issues on Java projects compiled with old Java versions.

Hope that helps!

I’m running Java 19 Runtime Environment

I updated to Java 21 and still can’t upgrade sonarlint.

Is the correct update site?

I dug a bit further and found I could download the update site for the latest release from SonarSource Downloads-CDN.

I grabbed and tried to install from that.

It found version 9.1, but failed with this error:

An error occurred while collecting items to be installed
session context was:(, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.apache.aries.spifly.dynamic.bundle,1.3.7
No repository found containing: osgi.bundle,org.objectweb.asm.commons,9.6.0
No repository found containing: osgi.bundle,org.objectweb.asm.tree,9.6.0
No repository found containing: osgi.bundle,org.objectweb.asm.tree.analysis,9.6.0
No repository found containing: osgi.bundle,org.objectweb.asm.util,9.6.0
No repository found containing: osgi.bundle,slf4j.api,2.0.9
No repository found containing: osgi.bundle,slf4j.simple,2.0.9
No repository found containing: osgi.bundle,org.objectweb.asm,9.6.0

This is strange, as I don’t recognize any of those bundles as SonarLint dependencies. Is it a clean installation of Eclipse 2023-09?

Can you retry to install it with or without checking this box: