Disabling system_call_filter


(Christopher Lankow) #1

After set bootstrap.system_call_filter: false in the
sonarqube-7.4\elasticsearch\config\elasticsearch.yml file I am still seeing the following log entries:

2018.11.28 07:36:52 WARN es[o.e.b.JNANatives] unable to install syscall filter:
java.lang.UnsupportedOperationException: seccomp unavailable: CONFIG_SECCOMP not compiled into kernel, CONFIG_SECCOMP and CONFIG_SECCOMP_FILTER are needed

2018.11.28 07:36:55 WARN es[o.e.b.BootstrapChecks] max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]
2018.11.28 07:36:55 WARN es[o.e.b.BootstrapChecks] system call filters failed to install; check the logs and fix your configuration or disable system call filters at your own risk


(Colin Mueller) #2

Christopher,

You should never touch the elasticsearch configuration files within the distribution we include in SonarQube.

Is there something in the requirements documentation around seccomp filter that isn’t possible in your situation?

Colin


(Christopher Lankow) #3

Turns out the messages that sounded menacing were actually only warnings and my issue was in another log file.