Disable Code Smell PR Comments on DevOps

I’m looking to disable the Code Smell PR Comments on Azure DevOps. I’ve seen several other threads and tried changing the configuration settings suggested; however, we still seem to be receiving the PR code smell comments.

What I’ve tried:

  • Disabled all code smell options for the quality gate
  • Disabled the summary comment option
  • Ignored the external Roslyn analyzer

Are there any other configuration options which may be related?

Hey there.

You would need to remove all Code Smells from your Quality Profile in order for those issues to no longer be decorated on your pull request.

Are there specific code smells you’re finding too noisy?

Hi Colin,

Thanks for the response. I’ve made some changes to the Quality Profiles and monitoring the results.

There is not any specific Code Smell being too noisy, rather we are currently monitoring the results before we enable the quality gate. Until we are ready to enable things we want to keep a clean slate.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.