Constantly getting Quality Gate failed: Compute engine task did not complete within time

We have bitbucket pipeline configured with sonarcloud-scan and sonarcloud-quality-gate. Since few days most of all attempts during working hours (8AM-5PM CET) are failing due to Quality Gate failed: Compute engine task did not complete within time:

  • versions used (sonarsource/sonarcloud-quality-gate:0.1.4 - also tried with 0.1.5)
 - pipe: sonarsource/sonarcloud-scan:1.2.0
 - pipe: sonarsource/sonarcloud-quality-gate:0.1.4
  • error observed:
Status: Downloaded newer image for sonarsource/sonarcloud-quality-gate:0.1.4
.............................................................✖ Quality Gate failed: Compute engine task did not complete within time
  • potential workaround - pipelines run successfully during evenings (~6PM CET)

This issue is critical and delays out development process.

Yesterday 2 attempts from more than 30 attempts have completed succesfully (even during evening/night). This problem chokes our development process…

The problem still occurs and chokes out development process. Any advices? What is the source of the problem? Any workaround/solution?

Hey @TomaszG,

Apologies for the late response, do you still experience the issue?
Did the tasks complete successfully if you go to sonarcloud.io?
The default timeout is equal to 5 minutes, you could potentially increase the timeout by setting the SONAR_QUALITY_GATE_TIMEOUT variable.

Best,
Marcin

Hi @Marcin_Majewski!
I’m still experiencing this issue… I have tried to set SONAR_QUALITY_GATE_TIMEOUT variable, but I face the same issue as described here. I have tried few options: “450”, ‘450’ (format suggested by the documentation) and 450, but so far no success (getting unsupported operand type(s) for //: ‘str’ and ‘int’ error).

I found this ticket that is related, but it’s still marked as unresolved.

Do you have any suggestions?

@Marcin_Majewski, did you get any updates on the bug? How can I move this topic further? It’s huge problem for us!

Hi @TomaszG,

New version of sonarcloud-quality-gate has been just released that fixes the bug with SONAR_QUALITY_GATE_TIMEOUT. The new version is: 0.1.6

Can you try with this one?

Best,
Marcin

@Marcin_Majewski Finally I was able to set the SONAR_QUALITY_GATE_TIMEOUT variable. I will observe the effectiveness of the new setup (for now it seems to work). Thanks for your support!