Connecting to sqlserver Database issue


I have an issue with connecting Sonarqube to sqlserver DB.

My SonarQube machine details:

Windows server 2019 STD
SQL server 2019 15.0.2000.5
SonarQube - Community Edition Version 9.7 (build 61563

I added this lines to the “” file in “conf” folder:

But, when I open the SonarQube web administration I still see the database alert embedded at the bottom.

I will be very happy to solve this.


Welcome to the community!

The # at the beginning of each line means those lines are commented out. :slight_smile:


Hello G Ann Campbell,
Thanks for your help, I tried to delete # Symbol and after this change when I run the Java service it is crushed, let me know if necessary more information, logs etc…


I don’t see anything out of the ordinary in your screenshot. And I don’t understand what you mean by “the Java service it is crushed”.

If the server isn’t running, you can check your server logs for errors. If you find any, feel free to copy/paste the text of the error logs here.