Code coverage is 0 in NET6

I use sonarqube developer 9.5.
working with azure devops pipelines.
the code coverage is not working in net6 projects
in other projects it works.

I have the the same pipeline for 2 different projects
in tests:
–collect “Code coverage”
and all works here:
SonarScanner for MSBuild 5.6

Using the .NET Framework version of the Scanner for MSBuild
Looking for TRX files in: D:\AzDevOps\Agent-08_w\12\TestResults

No test results files found

Did not find any binary coverage files in the expected location.

Falling back on locating coverage files in the agent temp directory.

Searching for coverage files in D:\AzDevOps\Agent-08_w_temp

All matching files: count=2


here in the NET6 linux version it is not working:
SonarScanner for MSBuild 5.6
Using the .NET Core version of the Scanner for MSBuild
INFO: ‘sonar.coverage.jacoco.xmlReportPaths’ is not defined. Using default locations: target/site/jacoco/jacoco.xml,target/site/jacoco-it/jacoco.xml,build/reports/jacoco/test/jacocoTestReport.xml
INFO: No report imported, no coverage information will be imported by JaCoCo XML Report Importer

the issue is the pipeline runner:
the code coverage is 0 only when I run on linux
when I run in windows everything is fine

It’s probably worth working your way backwards to figure out if the necessary files (that are imported by the scanner) are being generated when using Linux. If not – your problem starts before you run the scan.

checked everything, it seems like the is an issue with the linux scanner.
the same CI with windows sends the code coverage, but when I use a linux machine its not working

Colin, can you pm me