Client verbose output (timings)

I’m trying to enable verbose logging for the client part of analysis, particurarly I’m interested in timings, thus I’d like to see the timestamps in the output. But running Ant with ant sonar -Dsonar.verbose=true does not change output at all.
Am I missing something here?

Are you running this build manually, or from a CI server like Jenkins? If the latter, and you’re in a scripted pipeline, you can just put the block within a “timestamps” block.

This sounds like a workaround. I can get those timestamps in Jenkins, for sure, but I’m running it locally. Besides, I expect some extra output, as verbose=true implies.


Welcome to the community!

-Dkey=value on the Ant command line isn’t going to pass the arguments forward to the analysis process like you expect. Try setting it as a standard Ant property.


I forgot to mention this in my original post, but I have tried to put <property name="sonar.verbose" value="true" /> in the build.xml file and it makes no difference

Aaand having just checked the Scanner for Ant docs I see that they end with this:


Enable Debug Logs
To enable debug logs, use the regular Ant verbose option: -v

ant sonar -v

(where sonar is your target name)


Thanks Ann, it works. I probably missed that in the docs. No timestamps though. Is there any way to turn them on?

I’m not aware of anything off-hand, but the analyzers should include timings in their log output.