Can't run xcode build-wrapper due to hardened runtime

versions

Sonar 7.7 (23042)
Scanner 4.6.2.2472
build-wrapper, version 6.1 (macosx-x86)

error

When I run

build-wrapper-macosx-x86 --out-dir build_wrapper_output_directory xcodebuild clean build

I get

dyld: warning: could not load inserted library '/Users/user/tools/build-wrapper/libinterceptor.dylib' into hardened process because no suitable image found.  Did find:
	/Users/user/tools/build-wrapper/libinterceptor.dylib: code signature in (/Users/user/tools/build-wrapper/libinterceptor.dylib) not valid for use in process using Library Validation: mapped file has no cdhash, completely unsigned? Code has to be at least ad-hoc signed.

This is due to the hardened runtime and can be solved by building the build-wrapper application with this entitlement

Turns out that according to CPP-1640 this error can be ignored. The “hardened runtime” portion of the error lead me to believe this was a bigger deal than it was.

Once I ignored the error and let the build run, my analysis completed with no issues.