Cant connect to SQL Server with latest SQ version


We are using SonarQube ( LTS running from image on Azure App Services. We use SQL Server as database (also hosted in Azure).

We want to use AD authentication so are connectionstring is;database=dbname;encrypt=true;trustServerCertificate=false;hostNameInCertificate=*;loginTimeout=30;authentication=ActiveDirectoryMSI;msiClientId=d56e942f-xxxx-xxxx-xxxx-xxxxxxxxxxxxx

I have tried to update to the latest version 2 times but fails to connect to the sql server. I’ve read that there are problems when using the image so I changed approach. I have now setup an windows server 2022 in Azure VM and installed the latest version of SonarQube there. I followed the documentation and added mssql-jdbc_auth-12.4.1.x64.dll to the path (or actually put in i a couple of places ) .
The db has is_read_committed_snapshot_on enabled and its CS_AS

Then I start sonarqube if fails see attached
sonarlogwith10.3.log (77.6 KB)
log BUT if I install the latest LTS version 9.9.3 with the same connectionstring it works! What do I have to change to be able to use the latest sonarqube version???

Best Regards

Hi Pontus,

Welcome to the community!

What do your other server logs say?


Hi Ann

So web.log has a BindException: Address already in use: bind
not sure why, nothing else is running on that server. Not sure what it means.

es.log and ce.log are not updated guess sonarqube shutdown before anything is written to them

sonar.log (77.5 KB)
web.log (4.6 KB)


I’m guessing this was not the first time you attempted to start SonarQube? If so, it’s likely that a zombie process from the previous attempt is still holding the address. You may need to kill it manually.


Hi Ann
No its every time I start up sonarqube using that setting. I’ve also restarted the server a couple of times so shouldn’t be any zombie processes.


Hi Pontus,

Can you track down what process is using the port?


Just to double check, have SonarSource installed and setup the latest version on an empty server using SQL Server. Is that part of the QA process?

Hey @Pontus

Yes, that’s a part of our QA process.

I agree with @ganncamp that this doesn’t seem to be an issue with connecting to the database. Whatever is set as sonar.web.port in your conf/ file (default to 9000 when it’s set) isn’t available for the web server to start on. This is pretty easy to track down on windows.