Cannot loggin to Sonarcloud using Azure DevOps SSO

Hello folks,

After an email modification in my Azure DevOps account, I can no longer login to SonarCloud (SSO connection is the only way to connect)

Other users that have admin access can still see my account

Thanks for any assistance

Hi Clément,

Unfortunately, this will be considered as a new account and we don’t offer any account migration feature.

Can you please ask an administrator of your organizations so they can add your new account to the organization again?

Thank you

Hello Florian
thanks for the reply.

I already tried what you propose, but without success, here is why :

  • when the administrator deletes me → I can only sign-in using SSO ( Azure Devops in my case ) => redirect to the error page
  • when he deletes / adds me again → I can only login using SSO ( Azure Devops in my case ) => redirect to the error page.

I can neither login or sign in as it’s like the SSO between Azure and sonar is broken somehow.
Is there way to sign-in using classic email registration maybe, as a workaround ?

Hi Clément,

Would you please agree to ask the administrator to add you again? Currently your user seems to be assigned to no organization. Once done, I will continue the investigation. Thank you.

Hi Florian,
yes we tried several things, that’s why :wink:
I have been properly added to the organization again.

Let me know

1 Like