Can not view Compliant Solution in SonarLint IntelliJ Tool Window

  • Operating system: Windows 10
  • SonarLint plugin version:
  • Programming language you’re coding in: Java (Spring Boot)
  • Is connected mode used: with OR without SonarCloud
  • IntelliJ version: 2023.2.2 Ultimate Edition

When viewing a rule in the SonarList IntelliJ Tool Window, the Noncompliant code example textbox is displayed with an “infinite” height. This makes it impossible to view the rest of the rule, i.e., the Compliant solution:

Scrolling to the bottom, doesn’t help. In fact, the scroll bar keeps moving upward, as if the noncompliant textbox is still growing:

I have uninstalled and reinstalled the plugin, but the problem persists.

Hi @JakeAtON,

Is this the case for all the rules or just this one?

From what I can see, it’s at least every rule which has a “Noncompliant code example”:

Although, I looked around my project and found another rule with just a code example and watched it grow on its own until it filled up the window:

1 Like

Can you share the SonarLint logs by enabling Analysis logs and Verbose output?

How do I do that? FYI, it’s happening in my WebStorm too:

When you open the SonarLint Tool Window there is a options setting on the right side. You can click it and choose the Analysis logs and Verbose output. There is also a “Log” tab on the left of “Taint Vulnerabilities”. You can then introduce a new issue in a new file and trigger an analysis for it and the logs should be visible. Also, are you using the default settings of IntelliJ IDE? If not, is this issue occurring when you use default settings?

“Log” tab on the right of “Taint Vulnerabilities”*

Here is the (sanitized) contents of the log:
2023-10-06-sanitized.log (1.0 MB)

Here is a GIF of the problem in action:

If by “default settings”, you mean all of the app settings, no, they’re not the default. If you mean for the SonarLint plugin, the only thing I’ve changed is adding a connection to our SonarCloud projects. The problem occurred before that and has continued after removing the connection.

Hi @JakeAtON,

I reproduced the issue by clicking on the “Show virtual space at the end of the file” on IntelliJ settings.
Created this ticket for the issue:

Thank you

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.