Build-wrapper issue with nmake

For me build-wrapper is not working I tried below command

build-wrapper-win-x86-64.exe --out-dir bw-output nmake install_debug

build-wrapper.log****
Tue Nov 12 14:02:07 2019: build-wrapper, version 6.3 (win-x86-64)
Tue Nov 12 14:02:07 2019: isWow64: 0
Tue Nov 12 14:02:07 2019: windows version: 6.2, service pack: 0.0, build number: 9200, product type: 3
Tue Nov 12 14:02:07 2019: current directory: D:\fenix\girmeamo\Repos\Fenix\Messaging\Logistics\smrecmsgsrvmode
Tue Nov 12 14:02:07 2019: command line received:
Tue Nov 12 14:02:07 2019: initializing json file
Tue Nov 12 14:02:07 2019: starting debug cycle
Tue Nov 12 14:02:07 2019: process created with pid: 32160
Tue Nov 12 14:02:07 2019: image path name: <C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\bin\nmake.exe>
Tue Nov 12 14:02:07 2019: command line:
Tue Nov 12 14:02:07 2019: working directory: <D:\fenix\girmeamo\Repos\Fenix\Messaging\Logistics\smrecmsgsrvmode>
Tue Nov 12 14:02:07 2019: isWow64: 1
Tue Nov 12 14:02:07 2019: skipping process C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\bin\nmake.exe with pid: 32160
Tue Nov 12 14:02:08 2019: process created with pid: 13908
Tue Nov 12 14:02:08 2019: image path name: <C:\Program Files (x86)\JPSoft\TCCLE11\TCC.EXE>
Tue Nov 12 14:02:08 2019: command line: <C:\Program Files (x86)\JPSoft\TCCLE11\TCC.EXE /c echo - Compiling _verstub.cxx>
Tue Nov 12 14:02:08 2019: working directory: <D:\fenix\girmeamo\Repos\Fenix\Messaging\Logistics\smrecmsgsrvmode>
Tue Nov 12 14:02:08 2019: isWow64: 1
Tue Nov 12 14:02:08 2019: Probing C compiler: C:\Program Files (x86)\JPSoft\TCCLE11\TCC.EXE

Hi @AmolGirme,

is this the full content of the build-wrapper.log file? Nothing else in it?

As a side note, the latest version of the SonarCFamily C/C++ analyzer is now 6.4.

Hello @mpaladin,
Thanks for reply. Yes was full content.
BTW issue is resolved when analyse logs it was not working with TCC prompt but when I launch in windows command prompt build-wrapper had completed successfully .

Regarding SonarCFamily C/C++ analyzer, it is sonar-cfamily-plugin-6.3.0.11371 installed with sonarqube-enterprise-7.9.1
Now suddenly Scanner is giving following error.

10:55:22.338 INFO: ------------------------------------------------------------------------
10:55:22.340 INFO: EXECUTION FAILURE
10:55:22.340 INFO: ------------------------------------------------------------------------
10:55:22.342 INFO: Total time: 1:58.363s
10:55:22.439 INFO: Final Memory: 30M/114M
10:55:22.441 INFO: ------------------------------------------------------------------------
10:55:22.445 ERROR: Error during SonarQube Scanner execution
java.nio.file.InvalidPathException: Illegal char <:> at index 5: GNORE:4089
at java.base/sun.nio.fs.WindowsPathParser.normalize(Unknown Source)
at java.base/sun.nio.fs.WindowsPathParser.parse(Unknown Source)
at java.base/sun.nio.fs.WindowsPathParser.parse(Unknown Source)
at java.base/sun.nio.fs.WindowsPath.parse(Unknown Source)
at java.base/sun.nio.fs.WindowsFileSystem.getPath(Unknown Source)
at java.base/java.nio.file.Path.of(Unknown Source)
at java.base/java.nio.file.Paths.get(Unknown Source)
at com.sonar.cpp.analyzer.MsvcDriver.absolute(MsvcDriver.java:303)
at com.sonar.cpp.analyzer.MsvcDriver.onCapture(MsvcDriver.java:64)
at com.sonar.cpp.plugin.CFamilySensor.process(CFamilySensor.java:269)
at com.sonar.cpp.plugin.CFamilySensor.execute(CFamilySensor.java:205)
at org.sonar.scanner.sensor.AbstractSensorWrapper.analyse(AbstractSensorWrapper.java:48)
at org.sonar.scanner.sensor.ModuleSensorsExecutor.execute(ModuleSensorsExecutor.java:85)
at org.sonar.scanner.sensor.ModuleSensorsExecutor.execute(ModuleSensorsExecutor.java:62)
at org.sonar.scanner.scan.ModuleScanContainer.doAfterStart(ModuleScanContainer.java:82)
at org.sonar.core.platform.ComponentContainer.startComponents(ComponentContainer.java:136)
at org.sonar.core.platform.ComponentContainer.execute(ComponentContainer.java:122)
at org.sonar.scanner.scan.ProjectScanContainer.scan(ProjectScanContainer.java:400)
at org.sonar.scanner.scan.ProjectScanContainer.scanRecursively(ProjectScanContainer.java:395)
at org.sonar.scanner.scan.ProjectScanContainer.doAfterStart(ProjectScanContainer.java:358)
at org.sonar.core.platform.ComponentContainer.startComponents(ComponentContainer.java:136)
at org.sonar.core.platform.ComponentContainer.execute(ComponentContainer.java:122)
at org.sonar.scanner.bootstrap.GlobalContainer.doAfterStart(GlobalContainer.java:141)
at org.sonar.core.platform.ComponentContainer.startComponents(ComponentContainer.java:136)
at org.sonar.core.platform.ComponentContainer.execute(ComponentContainer.java:122)
at org.sonar.batch.bootstrapper.Batch.doExecute(Batch.java:73)
at org.sonar.batch.bootstrapper.Batch.execute(Batch.java:67)
at org.sonarsource.scanner.api.internal.batch.BatchIsolatedLauncher.execute(BatchIsolatedLauncher.java:46)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.base/java.lang.reflect.Method.invoke(Unknown Source)
at org.sonarsource.scanner.api.internal.IsolatedLauncherProxy.invoke(IsolatedLauncherProxy.java:60)
at com.sun.proxy.$Proxy0.execute(Unknown Source)
at org.sonarsource.scanner.api.EmbeddedScanner.doExecute(EmbeddedScanner.java:189)
at org.sonarsource.scanner.api.EmbeddedScanner.execute(EmbeddedScanner.java:138)
at org.sonarsource.scanner.cli.Main.execute(Main.java:112)
at org.sonarsource.scanner.cli.Main.execute(Main.java:75)
at org.sonarsource.scanner.cli.Main.main(Main.java:61)

Hi @AmolGirme,

as you opened a new topic I consider this one as solved.

Hello @mpaladin
Yes first problem is solved.
But after successful analysis of couple of projects (modules).
I am getting above error :

ERROR: Error during SonarQube Scanner execution
java.nio.file.InvalidPathException: Illegal char <:> at index 5: GNORE:4089

Hi @AmolGirme,

yes, and I already answered you: Sonar Scanner failed java.nio.file.InvalidPathException: Illegal char <:> at index 5: GNORE:4089.

Thanks @mpaladin