Build-wrapper is not running xcodebuild command

I’m running the following command:

build-wrapper-macosx-x86 --out-dir build_wrapper_output xcodebuild clean build

When I do so xcodebuild is not run. When I run:

xcodebuild clean build 

The xcodebuild command is invoked and there is a successful build. Why is it not working with build-wrapper-macosx-x86? The output json file looks like so:

# (C) SonarSource SA, 2014-2021, info@sonarsource.com
# All SONARSOURCE programs and content are copyright protected.
# SONARSOURCE and SONARQUBE are trademarks of SonarSource SA. All rights are expressly reserved.
#
# This file is designed exclusively for use with the SONARSOURCE C / C++ / Objective-C Plugin.
# It may not be used in connection with any other software.
# Any other use is prohibited by law and may be grounds for immediate termination of your License.
{
"version":"6.28",
"captures":[
]}

What happens?

When I run with build-wrapper-macosx-x86 it simply just exits. No errors. Seems like it silently fails?

Can you please attach your console logs showing what happens?

C02D47FMMD6R~/git(main|✚1…) % ./build-wrapper-macosx-x86 --out-dir build_wrapper_output xcodebuild clean build
C02D47FMMD6R~/git(main |✚1…) % 

If you’re asking for the log file generated in the output directory, can I send it via a message?