An exception occurred while running the Java custom rule

An exception occurred while running the Java custom rule,Looking forward to reply
sonarQube verison 7.9.0-SNAPSHOT
IDE eclipse
jdk 11 and jdk17
Exception info:

Caused by: java.lang.SecurityException: class "org.eclipse.jdt.core.dom.ASTUtils"'s signer information does not match signer information of other classes in the same package
	at java.base/java.lang.ClassLoader.checkCerts(
	at java.base/java.lang.ClassLoader.preDefineClass(
	at java.base/java.lang.ClassLoader.defineClass(
	at java.base/
	at java.base/jdk.internal.loader.BuiltinClassLoader.defineClass(
	at java.base/jdk.internal.loader.BuiltinClassLoader.findClassOnClassPathOrNull(
	at java.base/jdk.internal.loader.BuiltinClassLoader.loadClassOrNull(
	at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(
	at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(
	at java.base/java.lang.ClassLoader.loadClass(
	... 71 more

I have been in trouble with the same problems for 3 days,want solutions too!!!

hello, I figure out this issue!!! we need to open the java-custom-rules-examples project itself only,and then import neccessary maven dependencies.That will be ok.

Thank you both for posting this.
@weekdaysun: Does @shichuidaitoue’s solution solve your problem?

1 Like

Thank for your answer. It has been solved according to you said.The SonarQube version used in my project is 7.9, I also modified POM parent version

1 Like

It has been solved. Thank you

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.