Administration -> System tab doesn't load

The page under Administration → System takes extremely long to load.
After waiting for 15 minutes the page is still loading.
I would like this page to respond in a reasonable timeframe (e.g. <5 sec)

After inspecting the page the API call that takes very long is: /api/system/info

We have it hosted in a VM with some complicated network rules, but I connected via remote desktop to directly request the url via hosts file to make sure that doesn’t interfere.
(from the outside the page gives an 502 bad gateway after a few min)


  • SonarQube version 8.9.8. build 54436
  • Plugins: ShellCheck Analyzer v2.5.0, Sonar Cloudformation Plugin v2.1.9, YAML Analyzer v1.7.0

Tried to restart the server, but it didn’t help. I remember that when we first installed the server it was working and quite fast.

This was the response of the API:
{“errors”:[{“msg”:“Unknown url : /api/system/info”}]}

It seems any time we tried it, the SQL CPU shoots to a 100%. We tried increasing it from 20 DTU to 50 to 100 DTU but it’s still the same.

I would suggest regular database maintenance in that case (refreshing indices, refreshing statistics). What database provider (Microsoft SQL Server, Postgres, Oracle) are you using?

We are using Microsoft SQL Server as PaaS. We increased from 20 DTU to 200 DTU and this greatly reduced the time required albeit it’s still slow.
Initial request after startup: 2-3 minutes. Subsequent requests <30 seconds.

I will see if rebuilding indexes will significantly impact this load time.

Took a bit longer to get the correct permissions to our server.
Seems the usual DB maintenance scripts were not in place so, our indexes were severely fragmented and statistics were out of date. After updating them the system page is fast again(<1 sec).

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.