Add or update the header of the file

Even after adding the below updated header for java. Code smell issue is not getting fixed. Please help us to understand any format or any solution to fix the header issue

/**
2 * COPYRIGHT: Comviva Technologies Pvt. Ltd.
3 * This software is the sole property of Comviva
4 * and is protected by copyright law and international
5 * treaty provisions. Unauthorized reproduction or
6 * redistribution of this program, or any portion of
7 * it may result in severe civil and criminal penalties
8 * and will be prosecuted to the maximum extent possible
9 * under the law. Comviva reserves all rights not
10 * expressly granted. You may not reverse engineer, decompile,
11 * or disassemble the software, except and only to the
12 * extent that such activity is expressly permitted
13 * by applicable law notwithstanding this limitation.
14 * THIS SOFTWARE IS PROVIDED TO YOU “AS IS” WITHOUT
15 * WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED,
16 * INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES
17 * OF MERCHANTABILITY AND/OR FITNESS FOR A PARTICULAR PURPOSE.
18 * YOU ASSUME THE ENTIRE RISK AS TO THE ACCURACY
19 * AND THE USE OF THIS SOFTWARE. Comviva SHALL NOT BE LIABLE FOR
20 * ANY DAMAGES WHATSOEVER ARISING OUT OF THE USE OF OR INABILITY TO
21 * USE THIS SOFTWARE, EVEN IF Comviva HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22 **/

Hello @Jay_Parakh
and thanks for joining the community.
If I understand your message, you are struggling to get rule java:S1451 to work properly (i.e. to recognize the copyright content), on some project. Is that right?

Can you tell us more about your SonarQube version and your configuration of the rule on your SonarQube and the Quality Profile defined for this project?
Did you look at the existing threads about S1451 here? Did you check any config change yet, how did it go?

Best regards
Sylvain

@Sylvain_Combe
We do have same issue…
We are using: * Enterprise Edition * Version 7.9.1 (build 27448)
Yes, We defined the Quality Profile…

Hello @Bellamkonda
and welcome to the SonarSource community!
Rule S1451 has been in SonarQube for a long time and should work with your 7.9.1 as with recent, supported, versions.
Can you share some screenshot of:

  • this code smell raised on a file from your project
  • the quality profile selected for this particular project (Project Settings → Quality Profile)
  • the S1451 rule configuration in this particular Quality Profile, here is an example of my own: image