Add Anonymous Project Browse

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
  • how is SonarQube deployed: zip, Docker, Helm
  • what are you trying to achieve
    Temporarily allow anonymous project browse access
  • what have you tried so far to achieve this

I set the Force Authentication flag to False.
I also restarted the system.
Going to base URL still brings up login page.

I do have this configured with LDAP, though. Maybe that is forcing the login no matter what?

Do not share screenshots of logs – share the text itself (bonus points for being well-formatted)!

I figured it out.

I had to update my helm yaml file to have this set to False:

sonar.forceAuthentication: false

Seems that the helm properties override the switch in the UI.

All good now.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.