SonarLint analysis failed: Unable to load component class org.sonarsource.sonarlint.core.analyzer.sensor.SensorExecutor

FYI all SonarLint flavors (except Visual Studio) are affected.
I have created a tickets:

Seeing as this affects all IDEs across all OSX and Linux operating systems, is this going to be prioritized? hate to say it but this is the major selling feature of SonarCloud for our team.

This is a Windows only issue except if I missed something.

I’m running on OSX, a case sensitive OS. I suspect all case sensitive OSs are going to be affected by this issue.

Are you sure you are not confusing “case sensitive” and “case preserving” FS?

Still I will have a look at your storage (please give me access).

Julien - I am the one that originally created the issue and I too am running OSX so it does not appear to be limited to Windows machines.

Ah yes. I’ve double checked my file system and it’s case insensitive. My bad. So then this is an issue for all case preserving OSs, like OSX.

For what it’s worth my filesystem is APFS encrypted and is case insensitive. OSX Mojave 10.14.5 (18F132).

So yes, to sum up, we were both wrong: the issue affect all case insensitive filesystems (case preserving is not enough). I will update the ticket.

1 Like

Hi @dschnare and others,

Here is an attempt to fix the bug on VSCode. I would be grateful if you could test this artifact and report any issue:

I can easily provide build of other SonarLint flavors if someone else want to test.


I am available to test Intellij Ultimate if needed…

@romack here is a build:


Ran without issues. Scanned my source file in the IDE.

1 Like

Hi @Julien_HENRY, I’m seeing the same issue using the SonarLint plugin with Android Studio. Did the fix you provided also get applied to that plugin? Thanks

Hi @rmatze,

Android Studio is an IntelliJ flavor, so yes you can try the custom build ( to see if that fix your issue.

Hi @Julien_HENRY,

That did work. Thanks

Hello, for your information SonarLint for IntelliJ 4.1, which includes the aforementioned fix, is now publicly available from the JetBrains plugin repository.

A post was split to a new topic: SonarLint analysis failed in Eclipse: Unable to load component class SensorExecutor

I ran into a similar problem, when my environment was java16
I solved it by using java8. I hope you can get your reference.