Slow run of Load/download plugins

Template for a good new topic, formatted with Markdown:

  • ALM used Azure DevOps
  • CI system used Azure DevOps
  • Languages of the repository c#
  • Error observed

When running the scanner on a hosted build agent in Azure I observe that loading/download of plugins are really slow

User cache: /home/vsts/.sonar/cache
INFO: Load/download plugins
INFO: Load plugins index
INFO: Load plugins index (done) | time=74ms
INFO: Load/download plugins (done) | time=23846ms
INFO: Loaded core extensions: developer-scanner
INFO: Found an active CI vendor: 'Azure DevOps'

What can be done to make this run faster.

Hey there.

Unfortunately – there’s not much that can be done. ~250 MB of analyzer data needs to be downloaded and there’s no reliable caching mechanism that can be used on Azure DevOps Pipelines like is available on some other CIs.

I have two points to share:

  • We know downloads take longer when the version of Java used to run the scanner is 14+ (as Pack200 compression is no longer supported). It’s something worth double-checking, although your scanner environment is most likely on Java 11.
  • Eventually, we would like to do get these resources hosted on a CDN to improve availability. We aren’t there today

Just to have some numbers – how long does the rest of your build/analysis take? We know this is uniquely painful on smaller projects with otherwise short builds.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Hey @nlunn,

We recently improved the way we download plugins by deploying multi-region CDN for it. Have you noticed any improvements?


Hi Colin,

You say 250 MB of analyzer data ‘needs’ to be downloaded? But when I look at what is being downloaded it has files which are totally irrelevant to our project C# eg Scala, Groovy, flex, cpp etc.

If we had an option to select which data analyzers to download that would reduce the time by 90%+.

I have attached an image from our logs



Welcome David :slight_smile:

don’t hijack old threads, better open a new one.
Here are all the details for your problem


Thanks for the info Gilbert and also your efforts in trying to get this issue resolved.

Will refrain from hijacking in future. Cheers.