Community version startsonar.bat fails with Sonarqube requires JAVA 11+ to run

I need to test\assess how effective is Sonaqube so downnloaded the community version sonarqube-7.9.1 and installed JRE Version 8 Update 221

After downloading and extracting the file I executed StartSonar.bat and it fails with the error message as SonarQube require Java 11+ to run.
I have followed he section " Get Started in Two Minutes Guide", as per the product guide “SonarQube analysis requires version 8+ of the JVM and the SonarQube Server requires version 11+.” so since I am not using server version and have latest JRE 8 installed i should not get this error.

Can someone please help

There is no “server” version, there’s just having a SonarQube server, and uploading analysis results to it. :slight_smile: Java 11 is required for starting a SonarQube server, Java 8 or 11 is fine for executing an analysis.

1 Like

Thank you Colin, I am not a Java developer and only looking at PL\SQL analysis so please guide me here.

Based on your comment above I realized that apart from JRE i also need Java 11+ so i downloaded

Java SE Development Kit 12.0.2

Whats the next step do I need to set the path anywhere ?

Hi, I have the same issue here.
I downloaded and installed jdk-11.0.4_windows-x64_bin
But Im still having de same error SonarQube requires Java 11+ to run
What we should do to sonar find java to run?

If you have multiple versions of java installed on your server, you may need to define the path to the Java executable in the conf/wrapper.conf file of your SonarQube install directory

4 Likes

Could you please explain little more? If I edit the wrapper.java.command then I am getting another error.
Error: Unable to execute Java command. The system cannot find the file specified. (0x2) “\prince\bin\java**”
Critical error: wait for JVM process failed
So what value I have to provide for wrapper.java.command.1

1 Like

Hi,

see SonerQube doesnt start

Gilbert

I am also facing the same issue.Sonarqube requires 11+ run.I have set environment variable path and conf file as well.But facing same issue.
I am trying to download JRE 11 so I am not getting installable link only JDK 11 downloaded.
Could you please help.I am facing this problem since long but not able to start SonarQube.

open your wrapper.conf file (C:\SonarQube\conf\wrapper.conf), it has default:

# Path to JVM executable. By default it must be available in PATH.
# Can be an absolute path, for example:
#wrapper.java.command=/path/to/my/jdk/bin/java
wrapper.java.command=java

change it to (i have jdk12, you can adjust it)

# Path to JVM executable. By default it must be available in PATH.
# Can be an absolute path, for example:
#wrapper.java.command=/path/to/my/jdk/bin/java
#wrapper.java.command=java
wrapper.java.command=C:\Program Files\Java\jdk-12.0.2\bin\java

save, run C:\SonarQube\bin\windows-x86-64\StartSonar.bat to start SonarQube

4 Likes

This absolutely works .
Thanks

This worked in case of multiple JDK versions. Thank you.

thank you all , this forum really helps me, i can’t thank you all enough

A post was split to a new topic: Server won’t start up