XML-Analysis aborted

We’re using sonarsource/sonar-scanner-cli:latest docker image to scan the reports generated by OWASP dependency check - GitHub - jeremylong/DependencyCheck: OWASP dependency-check is a software composition analysis utility that detects publicly disclosed vulnerabilities in application dependencies..

This worked until dependency-check version 8. With version 9 that is now mandatory, we’re getting this error when scanning the XML report.

XML-Analysis aborted due to: Mandatory elements are missing. Plugin is compatible to https://jeremylong.github.io/DependencyCheck/dependency-check.2.5.xsd

Hey there.

I suggest opening an issue with the maintainer of the OWASP dependency check plugin here: GitHub - dependency-check/dependency-check-sonar-plugin: Integrates Dependency-Check reports into SonarQube