withSonarQubeEnv stuck after sonar analysis ends successfully

I’m using sonar in Jenkins pipeline on a java-script repository.
The repository contain few sub-modules, and sonar should analyze only one sub-module (the src is set in the sonar-properties file).
The repository size is around 2.5 millions lines of code, but the src that sonar should scan is only 85,000 lines.

When I run sonar analysis it get stuck. the analysis and all the methods inside the withSonarQubeEnv passed without any issue, but when withSonarQubeEnv should ends it get stuck and run until my slave get java.io.IOException: Unexpected termination of the channel error.

Also, when I’m aborning the build before the sonar stage, it somehow get stuck in this stage, like it cant get out of the withSonarQubeEnv .

When I scanned the sub-module outside the repository, with the same settings, it worked without any problem.

There are any limitation on the size of repository which contain the src? Even if the sonar should scan only part of the repository?

my sonar-properties:

sonar.language=javascript

# sources
sonar.sources=my_module/src
sonar.exclusions=my_module/**/node_modules/**

# tests
sonar.tests=my_module/src
sonar.test.inclusions=my_module/**/*.test.js

# tests reports
sonar.testExecutionReportPaths=my_module/reports/test-reporter.xml
sonar.javascript.lcov.reportPaths=my_module/coverage/lcov.info

sonar.verbose=true

The log, with some echo I added to debug the issue:"

13:28:28  INFO: Analysis report uploaded in 128ms
13:28:28  INFO: ANALYSIS SUCCESSFUL, you can browse http://my-sonar/dashboard?id=my-project
13:28:28  INFO: Note that you will be able to access the updated dashboard once the server has processed the submitted analysis report
13:28:28  INFO: More about the report processing at http:http://my-sonar/api/ce/task?id=my_id
13:28:28  INFO: Analysis total time: 42.122 s
13:28:28  INFO: ------------------------------------------------------------------------
13:28:28  INFO: EXECUTION SUCCESS
13:28:28  INFO: ------------------------------------------------------------------------
13:28:28  INFO: Total time: 43.887s
13:28:28  INFO: Final Memory: 42M/993M
13:28:28  INFO: ------------------------------------------------------------------------
[Pipeline] sh
13:28:28  + echo sonar analysis end
13:28:28  sonar analysis end
13:30:58  	at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:77)
13:30:58  
[Pipeline] }
[Pipeline] // script
...
java.io.IOException: Unable to create live FilePath for visslv09_u
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)
Finished: FAILURE

My sonar analysis stage:

stage('SonarQube analysis') {
    steps {
        script {
                withSonarQubeEnv("${my_sonar_env}") {
                    sh "${scannerHome} -Dsonar.projectKey=${myProjKey} -Dsonar.projectName=${myProjName}Dsonar.branch.name=${c_BRANCH_NAME} -Dproject.settings=${my-sonar-project.properties}"
                } // withSonarQubeEnv
        } //script
    } //steps
} // SonarQube analysis