Where is my Portfolio Settings button?

  • version 8.7.1 SonarQube
  • I created two security groups : sonar-administrators en sonar-quality-users
  • Both groups have exactly de same rights (they are almighty they have all rights)
  • I create a user account which is not linked to any LDAP
  • I put this user in sonar-administrators groups and I can create and edit Portfolio. I can see “Portfolio settings button”
  • Then, I removed the user from sonar-administror and I put him inside sonar-quality-users and I can create Portfolio at will. But the settings button “Portfolio settings” never appeared.

Have you any explanation to this strange behavior ?


Hi @Aurelien_Tricoire ,

The permissions for your sonar-quality-users probably does not have the same administrative rights to portfolios as sonar-administrators. Can you show screenshots of those 2 groups and their “Global Permissions”?


1 Like

Hi @Joe ,
As you can see, there are perfectly the same.

Hello @Aurelien_Tricoire ,

Can you post a screenshot of the portfolio’s permission settings (portfolio > Portfolio Settings > Permissions)?

Hi @Joe ,
It solves my issue.
I learnt that you need to create as administrator the portfolio and then apply portfolio permission to the sonar-quality-users group.
I thought it was sufficient to tick permission in Security menu. This is what I understood by reading the document. Maybe the documentation need an update ?


Thanks for confirming your solution! I agree that perhaps we should update the documentation.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.