Unable to Upgrade Sonarqube 8.9.9 to 9.9.1

  • I’m trying to upgrade from 8.9.9-community to 9.9.1-developer using Docker that runs on AWS Elastic Container Service (ECS).

So far is I’ve tried using Docker tags 9.9.1-developer, lts-developer, lts and 8.9.10-developer. When I used the first 3 tags, I would see a message about version being too old thrown by Java and that I should upgrade to LTS first, but with 8.9.10-developer tag it’s complaining about the web server version being too old (and that I should upgrade to LTS first).

Currently I’m using Docker tag 8.9.10-developer because I couldn’t find 8.9.10 LTS (it’s mentioned in the Downloads where they have zipfiles, but not in the Docker repo).

  • The database is PostgreSQL 12.14 running on AWS RDS; all other system versions come from Sonarqube Docker tag.

  • When the new container starts, it throws this error:
    Web server startup failed: Current version is too old. Please upgrade to Long Term Support version firstly.

Like I’ve mentioned, I cannot find the 8.9.10 LTS Docker tag, otherwise I would’ve used that.


Welcome to the community!

You’re getting that message because either the version you’re upgrading from is older than 8.9.* or the version you’re upgrading to is newer than 9.9.*.

You should take a close look at both ends of your upgrade and make sure they’re what you think they are. Because you can’t skip LTSs in your upgrade path.


Hi Ann! The version I’m trying to upgrade from is 8.9.9. However, if I just set this Sonarqube installation to use the same Docker tag as the one we currently have running in Production (basically, not upgrading, but just using the same tag), I get the same error.

I’m using a database that was left over from a previous installation of Sonarqube. It’s possible that its schema is older than the DB schema in Production. Is there a way to check it? I looked at properties and internal_properties tables, but didn’t find anything relevant.

Update: turns out the database is compatible with 7.9.6. I tried using the Docker tag for that version and the service came up.


That means you need to upgrade to 8.9 (start up the instance and run the database migration) before you can migrate to 9.9.1.


1 Like

I’ve tried running the service using 8.9-community and 8.9.0-community tags, got the same error about web server version being too old. I’ll try using something in between 7.9.6 and 8.9, like 8.0~8.3 or later

Tried using 8.0-community-beta, got the same error about web server startup failing due to the version being too old. Given that the error reads “web[o.s.s.p.PlatformImpl] Web server startup failed”, I suppose this has nothing to do with the database I’m using, but just to rule that out, is it OK that I’m using the same DB schema (running in AWS RDS) for backend between all these version?

Update: I went back to 7.9.6 and noticed a message in the logs that the database requires an upgrade, so I went through that and am now able to run 8.0. However, I’m unable to log in as ‘admin’ user, even after updating the database manually using instructions from documentation. That sounds like a separate issue though.

1 Like