Unable to open the rule in SonarQube

Hello Team,

I want to reduce the severity of one of javascript’s rule.
Rule Screenshot:


When I go to the rules list and try to open any of the javascript rules, It gives me an empty blank page, hence I am not able to modify the rule.
Screenshot below:

and when I try to open this URL in a new tab I get this error:
image

I tried it in incognito window it is still the same.
Is this a known issue? how do I modify the rule?
Adding @sohailshaikh001 for follow up…

Thanks,
Abhishek

Hi,

I can almost guarantee (99.999% certain) that this message did not come from SonarQube but from some intermediary on your network. So I would start with your network folks,

 
HTH,
Ann

Thanks for ur quick response Ann,

I don’t find this is because of network/proxy error, because I am able to open other rules and edit, it is specific to JavaScript rules.

Hi,

Then I don’t know what to tell you. Maybe you could double check with your network folks anyway? We don’t give out support IDs.

 
Ann

When I click on “why is this issue?” for any of the bugs/code-smells it gives me the information below as you see in the screenshot

Similarly, When I am trying to open the Javascript bug it doesn’t display me anything
Below is the screenshot:

Do you know why this could be?

Thanks,
Abhishek

Hi Team,

I am unable to open this rule in SonarQube:

When I try to open this I get an empty page:

This is specific to Javascript, rest other languages I am able to open.

I don’t understand why this is specific to javescript?

Thanks,
Abhishek

++ @sohailshaikh001

This is probably specific to “javascript:” because, as @ganncamp suggested, you have something between your computer and your server which applies some kind of filter which tries to eliminate “javascript:”, e.g.:

<a href="javascript:callMyFunction()">...</a>

That seems to be confirmed by you other thread which is probably not a bug in SonarQube…

Ok, thanks for your response, I was able to resolve by logging into server and updating the required things.

Thanks,
Abhishek