Unable to login to oracle database when Running Sonarqube with Oracle database using Docker image

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)

sonarqube:10.4.1-enterprise

  • how is SonarQube deployed: zip, Docker, Helm

Docker , Database : ORACLE

  • what are you trying to achieve

Running Sonarqube with Oracle database

  • what have you tried so far to achieve this

Followed all the steps provided online, When starting the SonarApp using docker, The container stops , The container logs shows
2024.04.10 16:33:05 INFO web[c.z.h.HikariDataSource] HikariPool-1 - Starting…
2024.04.10 16:33:06 DEBUG web[c.z.h.pool.PoolBase] HikariPool-1 - Failed to create/setup connection: ORA-01017: invalid username/password; logon denied\n
2024.04.10 16:33:06 DEBUG web[c.z.h.p.HikariPool] HikariPool-1 - Cannot acquire connection from data source
java.sql.SQLException: ORA-01017: invalid username/password; logon denied.

But i did provided valid JDBC URL, username and password provided in the docker compose file environment variables SONAR_JDBC_URL:
SONAR_JDBC_USERNAME:
SONAR_JDBC_PASSWORD:
NOTE: The same Database properties worked with a sample Java program. Not sure why it is failing with sonar application. I did rechekced the username / password . It is all good.
Do not share screenshots of logs – share the text itself (bonus points for being well-formatted)!

Hi,

Welcome to the community!

Did you provide the JDBC driver?

 
Ann

Yes, I did

Resolved the issue , I had a special character $ in my pwd and that needed to be escaped .

1 Like