Unable to load SonargraphMetrics.properties in Azure DevOps Pipeline build

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
    SonarQube Enterprise v8.1 (internally hosted)
    Azure DevOps Pipelines SonarQube extension v4.9.0
    Using Azure DevOps Services
    Using private shared build agents and servers based on MS hosted build servers.

  • what are you trying to achieve
    After upgrading to SonarQube Enterprise v8.1, we noticed this error during the SonarQube Run Code Analysis task within Azure DevOps Pipeline builds. Before the upgrade there was no error. These errors do not fail the task within the build. Is there an argument to be passed to resolve this or is this a bug?

##[error]09:44:06.118 ERROR: Sonargraph Integration: Unable to load custom metrics file ‘C:\Users\svcBuildZExmg/.sonargraphintegration/SonargraphMetrics.properties’

java.io.FileNotFoundException: C:\Users\svcBuildZExmg.sonargraphintegration\SonargraphMetrics.properties (The system cannot find the path specified)

##[error]at org.picocontainer.injectors.ConstructorInjector$1.run(ConstructorInjector.java:342)

##[error]at org.picocontainer.DefaultPicoContainer.getInstance(DefaultPicoContainer.java:699)

  • what have you tried so far to achieve this
    Confirmed we are using Java SDK 11.
    Googled for research.
    Tried Java 8 and still had same error.
    Tried different build machines.
    Reviewed Sonar documentation on implementation

Hi,

Welcome to the community!

This looks like a problem with the SonarGraph Integration plugin. You should raise an issue directly on the plugin.

 
HTH,
Ann