Typescript version issue

After migrating to Azure DevOps in the cloud we are now getting a typescript error during code analysis step in our .Net / SQL application with SonarQube on prem.

The TypeScript version we specified in our json package file is 4.0.5 but the error says

“You are using version 2.5.2 which is not supported: supported versions >=3.2.1”

Any suggestions on where to look?

Hello Ritesh,

Welcome to the community.

Which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)?

Turn on debug mode, and share the error in the logs in context; this will give more insight for inspection. Here are the ways to get debug level logs for your project:

  • Add /d:“sonar.verbose=true” to the BEGIN step with Sonar Scanner for .NET/MSBuild
  • Add sonar.verbose=true to the extraProperties key in SonarQubePrepare task with Azure pipelines yaml
  • And you could change your Log Level to DEBUG in your portal (Administration > System > Log Level) with no need to restart SonarQube


Regards,