Typescript files not getting scanned

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
    SonarQube v8.9 LTS, and sonarsource/sonar-scanner-cli v4.7

  • what are you trying to achieve
    When scanning a typescript project from GitLab CICD, the typescript files (ts,tsx) are ignored. When turning on the debug mode, the files are read and the job shows “EXECUTION SUCCES”. However, looking at the report, only CSS and HTML files are scanned. In the terminal, the following error is shown:

  • what have you tried so far to achieve this
    Tried to run with the sonar-scanner binary from my local machine. It is working correctly and the scan is also done as expected.

Hey there.

Thanks for the report.

Do you mind trying with the slightly older sonarsource/sonar-scanner-cli v4.6 to see if it makes a difference?

@Colin yes, it works with v4.6.

Thanks. We made quite a few changes between 4.6 and 4.7 (like changing the base image used). I’ll flag this for attention, but for now you have a workaround.

Thanks a lot.

Hey @kxt5258

See this update here: