Terraform security hotspots not appearing in IDE

OS: Windows
Plugin version: 8.1.0
Language: Terraform
Connected mode: SonarQube 9.9.0 developer edition

I have some security hotspots reported in SonarQube (not reviewed as yet), but these do not appear in the SonarLint security hotspots tab.

Furthermore, when I attempt to open the hotspot from SonarQube in my IDE there is an error “The Security Hotspot you tried to open could not be detected by SonarLint in the current code.”

The binding is correct, I have other (non-terraform) projects working and showing hotspots correctly, so this issue could be limited to Terraform.

I have also tried to open the project in VSCode, and again there are no security hotspots reported.

Hi @Kelsier,

Terraform analysis is not yet enabled in IntelliJ or VSCode, which means you cannot open Terraform security hotspots from SonarQube to your IDE. It should be available in the upcoming release for both IDE later this month.

Thank you for using SonarLint!

Thanks Nicolas

I look forward to the update

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.