SQ 8.4.1 Security Reports, page extension failed with Edge


in Edge (Version 83.0.478.64 64-Bit) when using the Security Reports link on a project dashboard
i get a ‘page extension failed’ error

Don’t see any related log entries with loglevel debug, but the browser dev tools console has

VM63 securityreport.js:1 Uncaught TypeError: Object(…) is not a function
at Module. (VM63 securityreport.js:1)
at n (VM63 securityreport.js:1)
at Object. (VM63 securityreport.js:1)
at n (VM63 securityreport.js:1)
at Module. (VM63 securityreport.js:43)
at n (VM63 securityreport.js:1)
at Object. (VM63 securityreport.js:19)
at n (VM63 securityreport.js:1)
at VM63 securityreport.js:1
at VM63 securityreport.js:1

It works fine with Chrome (version 77.0.3865.75), didn’t test with other browsers.


In the meantime the error has gone ?! :thinking:

Strange. Do you thing that could be a matter of refreshing the web ui or something? Please come back to us if the issue happen again, or if you are able to reproduce it.

Not sure, started my browser with several tabs as usual.
Open a new one for Sonarqube and after login navigate to the dashboard of an existing project.
Then i hit this error, tried with other project dashboards and got the same error for all.
Tried again three hours later and the error has gone, didn’t clear the browsers cache.
Could not reproduce this behaviour, will come back if it occurs again.