SonarSource Build Wrapper not picking up any information with catkin build

I’m using SonarQube Developer Edition - Version 9.2.1 in a complex C++ project.

I’m trying to use the build wrapper to collect information about our build configuration during build time and we use “catkin” to build files. This ROS-based tool is described as being “implemented as custom CMake macros along with some Python code.”

I have been able to run the wrapper with commands such as “catkin build” and “catkin clean && catkin build” successfully, but each time it creates an empty “build-wrapper-dump.json” file.

As far as I understand it catkin is doing a few extra steps but it still uses CMake under the hood. I’m wondering if anyone at SonarSource is familiar with this tool and has any advice on how to get this to work properly?

Is catkin supported?

Hi @tnhjhu ,

what compiler are you using?

@mpaladin We are using GCC 8 for this project.

Hi @tnhjhu ,

could you please share the build-wrapper output directory? I can send you a PM if you prefer to share privately.

I tried to responded via PM but I am not seeing the ability to message you directly.

Do you need to see the contents of the wrapper directory? It never worked for catkin, I had to use the compile_commands.json file that was created with every subproject using catkin build -DCMAKE_EXPORT_COMPILE_COMMANDS=1 and consolidate those files into one file for the scanner.

Hi @tnhjhu ,

I sent you a private message. Are you using build-wrapper or compilation database? Did you solve your issue?