SonarQube stuck on "Loading..."

Hey guys, I’m having this problem when I try to start sonar it keeps get stuck on the “Loading…” screen and it won’t do anything besides that. I have it deployed through Google Kubernetes Engine. A pod is hosting Sonarqube using version 6.7.6, I’ve a service exposing the pod to the cluster and then I’ve an Ingress that redirects traffic from the outside to the corresponding service. I’ve checked Sonar’s path in the Ingress and everything seems alright, same with the ports.

Here’s the path in the Ingress configuration:

backend:

      serviceName: sonarqube-sonarqube

      servicePort: 9000

    path: /sonar

    pathType: ImplementationSpecific

Thank you all

Try setting pathType to Prefix instead of ImplementationSpecific. If you using the helm chart, it looks like you can’t do it through there. I ran ‘helm template’ and manually changed it in the yaml then manually applied it. I know that is hacky, but there doesn’t seem to be a way to do it by passing in a value through helm.

@Furman950 Thank you for sharing this feedback (and welcome to the community :wave: ). I have created DOCKER-35 in order to let this be configurable in the future :slight_smile:

@DavidGarcia your sonarqube version is heavily out of date… if you are starting fresh anyway you should aim at least for the current LTS (8.9) or the latest release (9.2 as of writing).
if you problem does persist after upgrading to a newer version of sonarqube, please try to clear your browsers cache and if that does not help, provide some more information (including js log in the browser) about the problem so we can troubleshoot it

1 Like