Sonarqube skip test

Hi, i use SonarQube 7.1 with maven. When i use sudo mvn -e sonar:sonar \ -Dsonar.host.url=http://localhost:9000 -DskipTests=false

sonar skip the test:

< Blockquote>

[INFO] ninja … SUCCESS [ 11.720 s]
[INFO] ninja-core … SKIPPED
[INFO] ninja-postoffice … SKIPPED
[INFO] ninja-websockets-jsr356 … SKIPPED
[INFO] ninja-servlet … SKIPPED
[INFO] ninja-standalone … SKIPPED
[INFO] ninja-test-utilities … SKIPPED
[INFO] ninja-jaxy-routes … SKIPPED
[INFO] ninja-metrics … SKIPPED
[INFO] ninja-metrics-graphite … SKIPPED
[INFO] ninja-metrics-ganglia … SKIPPED
[INFO] ninja-metrics-librato … SKIPPED
[INFO] ninja-metrics-influxdb … SKIPPED
[INFO] ninja-maven-plugin … SKIPPED
[INFO] ninja-servlet-integration-test … SKIPPED
[INFO] ninja-servlet-jpa-blog-integration-test … SKIPPED
[INFO] ninja-servlet-jpa-blog-archetype … SKIPPED
[INFO] ninja-servlet-archetype-simple … SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ----------------------------

Welcome to the community Forum! What about removing that skipTests flag ? The default behaviour is to execute tests.