SonarQube service is not getting restarted

Hi,

I have created SQ 7.9.6 setup on Kubernetes platform and it’s working as expected.

It is observed that SQ service is not getting restarted when I try to restart from web.
Administration > System > Restart Server

When I checked the logs, I am getting below warning messages continuously:

2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'buildbreaker' version : 2.3.1.347 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'c' version : 1.0.0 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'csharp' version : 7.15.0.8572 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'cssfamily' version : 1.1.1.1010 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'cxx' version : 1.0.0 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'flex' version : 2.5.1.1831 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'gherkin' version : 1.7 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'go' version : 1.1.1.2000 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'jacoco' version : 1.0.2.475 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'java' version : 5.13.1.18282 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'javascript' version : 5.2.1.7778 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'kotlin' version : 1.5.0.315 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'ldap' version : 2.2.0.608 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'php' version : 3.2.0.4868 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'python' version : 1.14.1.3143 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'ruby' version : 1.5.0.315 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'scmgit' version : 1.12.1.2064 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'scmsvn' version : 1.9.0.1295 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'sonarscala' version : 1.5.0.315 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'typescript' version : 1.9.0.3766 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'vbnet' version : 7.15.0.8572 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'web' version : 3.1.0.1615 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'xml' version : 2.0.1.2020 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'authgithub' version : 1.5.0.870 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'authsaml' version : 1.2.0.682 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'backelitesonarswiftplugin' version : 0.4.4 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'buildbreaker' version : 2.3.1.347 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'c' version : 1.0.0 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'csharp' version : 7.15.0.8572 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'cssfamily' version : 1.1.1.1010 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'cxx' version : 1.0.0 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'flex' version : 2.5.1.1831 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'gherkin' version : 1.7 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'go' version : 1.1.1.2000 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'jacoco' version : 1.0.2.475 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'java' version : 5.13.1.18282 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'javascript' version : 5.2.1.7778 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'kotlin' version : 1.5.0.315 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'ldap' version : 2.2.0.608 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'php' version : 3.2.0.4868 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'python' version : 1.14.1.3143 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'ruby' version : 1.5.0.315 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'scmgit' version : 1.12.1.2064 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'scmsvn' version : 1.9.0.1295 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'sonarscala' version : 1.5.0.315 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'typescript' version : 1.9.0.3766 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'vbnet' version : 7.15.0.8572 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'web' version : 3.1.0.1615 has not been found on the update center.
2021.07.07 11:28:41 INFO  web[AXqAqIDyE38m+gcbAAEp][o.s.u.c.UpdateCenter] The plugin 'xml' version : 2.0.1.2020 has not been found on the update center.

Please help me to resolve the issue.
Thanks,
Vaibhav Jariwala

Hi,
Do you have any other relevant logs in other log files (web.log and ce.log)?
Can you check in your browser, with developer tools, what is the response of the call to the endpoint api/system/restart?

Issue is resolved. One plugin version mismatch was giving an issue.
Thanks for your help.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.