SonarQube fatal error: typescript not analyzed

typescript file is not analysed by sonar qube .please advise me.
am in trouble

but its working sonar qube 7.7

FATAL ERROR: Ineffective mark-compacts near heap limit Allocation failed - JavaScript heap out of memory

Environment used

sonarqube 8.0 community edition
sonar scanner 4.1
jdk 11

please help us

mail me : Muralidharan@cicgogo.com
whatapps no :+919884056988

Hi,

Try to set analysis property sonar.javascript.node.maxspace to 4096 or 8192.

If it does not help please provide full analysis logs.

which file I have to set these properties

sonar.javascript.node.maxspace to 4096 or 8192 .

please advise us

you can add it to sonar-project.properties file: sonar.javascript.node.maxspace=4096

or pass in scanner command: sonar-scanner -Dsonar.javascript.node.maxspace=4096

Hi Elena,
I am also getting the same error (“FATAL ERROR: Ineffective mark-compacts near heap limit Allocation failed - JavaScript heap out of memory”) while running sonar-scanner to one of the component.
I have tried by adding “sonar.javascript.node.maxspace” to “4096” and “8192” to the properties file, but still getting the same error. Could you please help me to resolve this error?

Environment used
nodejs - v13.8.0
SonarQube Scanner 3.2.0.1227

Attaching the full analysis log file.
sonarScanner_analysis_logs.txt (748.4 KB)

Thanks & Regards,
Prashanth.

Hi @Crasta

Indeed you have the same error, but I’m not sure you realize that your analysis actually fails due to NullPointerException during C-family analysis.

Could you start a new thread about that C-family problem?

Concerning the JS Heap out of memory, try to update SonarCSS analyzer (SQ 7.9 is required).

Hi @Lena ,
I am facing this issue in C++ code only.
We have combination of both C & C++ files. Out of which for all C files, sonar-scanner is able to run successfully. Issue i am getting only for C++ files.
Attaching the error log file which i run for individual C++ file.
SonarScanner_Error_CPP_File.txt (39.1 KB)

Thanks & Regards,
Prashanth.

Hi @Crasta,

during the analysis we try to run /home/crasta/Perforce/Crasta_Fedora/OTV_OS/Opentv5/DEVELOP/DEV_ALEXA_NEW/otvtarg/ref/sagem7252s_glibc_bc/dev_hybrid/host/bin/toolchain-wrapper, -x, c++, --std, c++14, -v, -dM, -E, - and we get the following error:

/local/toolchains/stbgcc-6.3-1.1/bin/toolchain-wrapper: No such file or directory

Does it ring you any bell? Are you removing toolchains between the build and the analysis?