SonarQube 8.9.7 is stuck in starting mode

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension) SonarQube 8.9.7
  • how is SonarQube deployed: zip
  • what are you trying to achieve:

I have tried to bring up SQ but it got stuck in starting/loading phase. I see tons of msg like this es.log:


023.09.12 12:14:54 DEBUG es[][o.e.i.s.ReplicationTracker] no retention leases are expired from current retention leases [RetentionLeases{primaryTerm=63, version=2272, leases={peer_recovery/aasssxx=RetentionLease{id='peer_recoveryQqknyJUgCM1xuNQ', retainingSequenceNumber=27, timestamp=1694530833524, source='peer recovery'

Also in Web Log I see this message:


2023.09.12 12:10:26 DEBUG web[][o.p.c.v.ConnectionFactoryImpl] Trying to establish a protocol version 3 connection to san-mech-dbsonar-5:5432
2023.09.12 12:10:26 DEBUG web[][o.p.c.v.ConnectionFactoryImpl] Receive Buffer Size is 184,640
2023.09.12 12:10:26 DEBUG web[][o.p.c.v.ConnectionFactoryImpl] Send Buffer Size is 43,520

  • what have you tried so far to achieve this
    I tried to restart multiple times. First I thought it might be a DB issue, so I start our PostGreSQL db but no luck. This instances has been running for a while.

Do not share screenshots of logs – share the text itself (bonus points for being well-formatted)!

Hi,

Welcome to the community!

Your version is past EOL. You should upgrade to either the latest version or the current LTS at your earliest convenience. Your upgrade path is:

8.9.7 → 9.9.1 → 10.2 (last step optional)

You may find these resources helpful:

If you have questions about upgrading, feel free to open a new thread for that here.

Regarding your error, if this is in service to an upgrade to a current version, please turn off debug logging and post your server logs.

 
Ann

I cannot upgrade at this point. Would you please recommend some option for troubleshooting. I have the same version running in prod with no issue. This was also working till few days ago. Should I delete data/es7 folder? Does updating statistic on the database side help?

Hi,

I really can’t help you with a non-current version.

Perhaps if you turn off debug logging and take a look at your server logs, you’ll find the answer in whatever errors show up there.

 
Ann

The debugging on and there is no error and any useful logging except what I listed above. The Sonarqube GUI is only shows ‘starting’.