SonarLint not found in Eclipse after install


(Tim Hughes) #1

I have installed SonarLint 4.1 from Eclipse Marketplace, but when I try to configure it via Window > Show View > Other… there is no selection for Sonar or SonarLInt. I have also tried looking in Preferences, as well as right-clicking on my project and picking Configure. Eclipse says it is installed, but cannot find it anywhere. I have installed/uninstalled/reinstalled several times to no avail.

Running Eclipse 4.10 (2018-12) using OpenJDK 11.0.1+9 on MacOS 10.13.6


(Julien Henry) #2

Hi Tim,

Can you look at Eclipse logs to see the error when loading the plugin?


(Tim Hughes) #3

Julien:

There is nothing in the log related to Sonar/SonarLint/SonarQube. Only some errors related to mylyn and oomph.


(Tim Hughes) #4

I checked Eclipse.app/Contents/Eclipse/Plugins directory, and don’t see SonarLint plugin files there. Questions:

  1. Is that the correct location on Mac for the plugin to be installed?
  2. Is there a way for me to install manually to this location? I see there are files available (https://binaries.sonarsource.com/SonarLint-for-Eclipse/releases/), but no instructions on how to properly install.

(Julien Henry) #5

The best way to install is to use the Eclipse p2 client, or the marketplace. Manual installation can also be done using the dropins feature.
But copying files in plugins or features folder is very likely to fail and break your Eclipse installation (there are various caches in some places).

You can read https://ekkescorner.wordpress.com/2009/06/27/galileo-install-plug-ins-into-eclipse-ide/ for more details.


(Tim Hughes) #6

Tried several different ways to install, but eventually had to reinstall Eclipse in order to get SonarLint to work. Everything is now working properly with the new Eclipse install.


(Julien Henry) #7

Thanks for the follow up, Eclipse is sometimes picky.