Sonarlint Connected Mode has too many active rules from unused languages

  • Operating system: Windows 11 Pro
  • SonarLint plugin version: 10.6.1.78652
  • Programming language you’re coding in: Java
  • Is connected mode used: Yes
    • Connected to SonarQube: 9.9 LTS

Wondering why my Sonarlint log contains rules about Kubernetes, although it is not marked to do so.

Sonarqube Server
Sonarqube > Quality Profiles > Kubernetes
Sonar way BUILT-IN, default, Used: never

Sonarqube > Projects > MyProject > Project Settings > Quality Profiles
Java

From my understanding, with these settings, Kubernetes will not be activated for this project.

IntelliJ SonarLint
IntelliJ > View > Tool Windows > SonarLint > Log

INFO sonarlint - Triggering analysis with configuration: [
...
extraProperties ... sonar.kubernetes.activate=true
activeRules: [kubernetes:S6431,...

This indicates, that SonarLint will check for Kubernetes rules.

I tried several solutions:

  • Copy default Kubernetes Quality Profile and deactivate all rules. When I try to set this to default, I can’t with message “You must activate at least 1 rules before you can make this profile the default profile.”
  • Sonarqube > Projects > MyProject > Project Settings > General Settings > Languages > Kubernetes > Deactivate (sonar.kubernetes.activate)
    When I rerun SonarLint, it is still set to true (maybe I missed updating Server config?). Still, this solution would mean I have to go though all projects and set this explicitly, which should not be the way to go.

Kubernetes is only an example, I feel like a lot of rules are activated for SonarLint that shouldn’t (python, css, …). Is this really the way it is intended to behave?

Any help is appreciated.

Hey there.

Unless you have a Kubernetes file open… this really isn’t causing any harm. What’s the motivation to ignore these rules entirely?

1 Like

My motivation was

  • Simplicity
    clean log output (active rules list, skipping analysis)
  • Performance
    load unused rules data from ‘connected mode’ server

Happy to hear that this is no problem though.

Thanks! :v:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.