Sonarlint api requests getting stuck on IIS

Operating system: Windows 10
IDE name and flavor/env: Visual Studio, Rider

Hello, since few weeks I have started to notice lot of requests from sonarlint api get stuck on our IIS server. These requests then cause our server to stop responding once enough of them get stuck. Pasting screenshot from current situation where 5 of them are stuck but site is still responding.

I am not sure what I can do here to avoid this. Since the requests are from multiple pc’s it’s hard for me to pinpoint which IDE it is and what version of sonarlint it is but most of our devs use Visual Studio and few use Rider.

Any help on this will be great.

Hi,

I’m not sure I understand. Your title says the requests are getting stuck in IIS. Does that mean the proxy is not passing them on to the server? Meaning that when you check your $SONARQUBE-HOME/logs/access.log the requests don’t show up there?

If so, that sounds like an IIS problem…?

 
Ann

Hi, There are requests going through and showing up on access.log but I don’t know if there is some way for me to verify that the stuck requests got through or not.

Hello @sk2312,

The requests are not stuck, this is expected behavior. SonarLint instances that are connected to your SonarQube open a long connection to receive events about what happens in SonarQube. To achieve this, we leverage the server-sent events concept. This helps keep SonarLint in sync with the server almost in real-time, regarding for example changes in the quality profiles, issues, SecurityHotspots, etc. The goal is to bring a better experience to developers.

This mechanism exists for all SonarLint flavors, including Rider and VS.

I don’t think there is a way to globally turn off the feature, I can check. Are there a lot of active developers in the company? Could you treat those requests differently in IIS, or augment the capacity?

2 Likes

Thanks for the reply. Yes we have quite a few developers. I will try and increase the capacity and see if that makes any difference.