SonarCloud - Repo Overview page displaying page load spinner rather than overview


  • ALM used: GitHub
  • CI system used: Github Actions


  • Microsoft Edge - In Private Tab
  • Logged into SonarCloud via github integration

Steps to reproduce

  • Select a repo
  • The overview page opens - a spinner appears on the page below the link bread-crumbs
  • In left hand navigation bar click main branch - I see a spinner on the page below summary
  • Click through the sub links
    • Summary - doesn’t load
    • Issues - loads with data
    • Security hotspots - loads with no issues found.
    • Measures - Page Spinner


  • In the dev console I see “Fetch failed loading: POST”
  • Happening on repos that are “Analyzed by Github actions” or “Analyzed by SonarCloud”

Hey there.

Thanks for the report.

I can’t reproduce this. Are you still facing an issue?

Yes - it’s still happening throughout my sonarcloud instance.

I’ve reached out privately for additional information.

Solution: Disable NordVPN - Web file protection

Troubleshooting steps

  • Disabled all the extensions (That I think might impact it)
  • Made sure no vpn is running
  • Turn of all windows defender profiles (domain, private, public).
  • loaded page- it worked!
  • turned back on all 3 firewall profiles.
  • page still worked
  • rebooted computer
  • NordVPN auto-restarted