Sonar-scanner: not found

I am using ,
SonarQube version:6.4, Sonar Scanner version:

I am trying to achive to integrate AWS codecommit with SonarQube.

so far I tried,

  • Installed sonar-scanner on the same server where SonarQube existing.
  • sonar-scanner properties file: changed default localhost property to the exisitng instance.
    -In build yml file SET Pathvariable
    export PATH=$PATH:/opt/sonarscanner/sonar-scanner-
  • Tried following command
    sonar-scanner as well as tried sonar-scanner -Dsonar.login=token

Getting sonar-scanner: not found error in build, Could anyone please tell if any configuration I am missing?


First, the current version of SonarQube is 7.7 (7.8 imminent) and the current LTS is 6.7.7. You’re going to have a hard time finding help for versions older than that.

That said, from what I can tell your error is about not finding the sonar-scanner in your path. That’s a little out of scope for this community. Have you tried having your build process echo $PATH to make sure the values you expect actually end up there?