Sonar Scanner execute fails

Hi Team,

When I try to run the command for the sonar runner at the end an error message "org.springframework.beans.factory.UnsatisfiedDependencyException: Error creating bean with name ‘org.sonarsource.scanner.api.internal.IsolatedClassloader@49139829-org.sonar.scanner.report.ReportPublisher’: Unsatisfied dependency expressed through constructor parameter 7; "
is being displayed along with sonar execute fails due to it. I have attached the logs files and also the error message for the same. Please find the software details and version being used. The log files along with the error message is attached for reference purpose.

SonarScanner for MSBuild 5.5.3,
SonarQube - 9.4.0.54424,
SonarScanner 4.6.2.2472
Java 11.0.14 Oracle Corporation (64-bit)
Windows 10 10.0 amd64
Error.txt (17.2 KB)
sonarqube_es.log (8.3 KB)
sonarqube_ce.log (1.6 KB)
sonarqube_web.log (54.8 KB)
sonarqube_app.log (4.0 KB)

Thanks,
Deepak.

Hi,

Welcome to the community!

The root error is this:

Caused by: java.lang.IllegalStateException: Fail to request url: http://localhost:8080/api/rules/search.protobuf?f=repo,name,severity,lang,internalKey,templateKey,params,actives,createdAt,updatedAt,deprecatedKeys&activation=true&qprofile=AYBA8tyLlf7dqTvaax50&ps=500&p=1
...
Caused by: java.net.SocketTimeoutException: timeout
...
Caused by: java.net.SocketTimeoutException: Read timed out

Since there are no errors in your web.log, this is more than likely caused by something on your network, such as a proxy, interfering with the traffice. You should talk to your network folks.

 
HTH,
Ann

Hi Team,

I checked with Networking team still the issue persists and I have also tried the same in my personal laptop but still getting the same error. Any other solution for this can you please let me know.

Thanks,
Deepak.

Hi Deepak,
Do you have any news about this?
I have the same problem and I still don’t know what the solution is.

Hi Alison,

Still it is not working and I don’t have any update or solution for the same.

Thanks,
Deepak

Hello,

we are having the same problem. It started yesterday and doesn’t seem to have anything to do with our stack.
I can provide logs and stack traces if you are interested.

UPDATE: here is our stacktrace Stacktrace.txt (38.6 KB)

@ganncamp @Deepak916

I took a look at the application code and traced the issue to the following post MR scanning breaking after upgraded to SonarQube Developer version 9.5 and [SONARJAVA-4267] The Java analyzer crashes when running incremental analysis on generated files - SonarSource.

A mitigation to apply in the meantime is to disable the use of the cache during the pr analysis by adding the parameter
sonar.analysisCache.enabled=false

UPDATE: It worked for us.

I had same problem, resolved after I removed
sonar.scm.disabled=true
from the sonar-project.properties

1 Like