Sonar.organization defined to default is reported as not defined

Must-share information (formatted with Markdown):

  • which versions are you using:
    • Sonarcloud
    • org.sonarsource.scanner.maven:sonar-maven-plugin:3.6.0.1398:sonar
  • what are you trying to achieve
    • publish analysis
  • what have you tried so far to achieve this
    • tried with local Sonarqube instance 8.0 and 8.2 and it is working fine

we have sonar.organization defined to “default” as suggested a whiel ago. it is no more working. This error is reported:

19:08:26 [ERROR] Failed to execute goal org.sonarsource.scanner.maven:sonar-maven-plugin:3.6.0.1398:sonar (default-cli) on project project: You must define the following mandatory properties for ‘fusetools:org.fusesource.ide:project’: sonar.organization -> [Help 1]

the property is defined in sonar-project.properties

Has it changed? Should we define something else?

regards,

Hi,

Indeed it seems to be a regression introduced by a recent change related to organization.

I’m still investigating to find what causes this regression.
In the mean time, you can move the property sonar.organization from your sonar-project.properties to the <properties> section of the pom.xml file. It should fix the problem.

Regardless of this issue, I’d suggest that you move* your project to your own organization for several reasons:

  • By importing your organitzation and project directly from GitHub, you will benefit of better GitHub integration (like feedback in PR, members synchronization, etc.)
  • You will have full administration permission on the organization your projects belongs to.

Hope that helps,

Benoit

*Moving a project from one organization to another is currently not supported. You will have to create a new project in your new organization.

1 Like