Sonar Not Leaving Setup Mode during upgrade

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
    6.7.5 current version -> 6.7.7 new version. (Both community versions)
  • what are you trying to achieve
    I was trying to upgrade our production system from 6.7.5 to 6.7.7 (so we can get to even newer version)
  • what have you tried so far to achieve this
    When the new software was installed I ran /setup. The “Database is up-to-date” page displayed, but when I went to the home page is kept saying sonar is starting and forwarded me to the maintenance link.
  • I tired going through the process several time (reverting to the previous version and starting up the new version - we have the software side by side until upgrades and complete and tested).
  • Looking at logs -> seeing no errors in any of the log files
  • online searches on mentioned doing the /setup which ran correctly
  • I followed the same process for our QA server and it worked with no problems.

Any ideas on how to get out of maintenance mode would be greatly appreciated. Thanks!

Hi,

Welcome to the community!

The bad news is I have no clue what’s going on here. The good news is that you don’t need to do this point upgrade before you can move forward to 7.9.3 (and then beyond!).

So… maybe just skip this minor upgrade and jump straight to the even newer version that’s your ultimate target?

 
:woman_shrugging:
Ann

The documentation said I needed to hit all LTS releases to upgrade to releases above them. If you are confirming that, I can try to go to version 7.8 which is my next target since we want to change the database as one change by itself.

We determined that setup was returning successful in a browser despite being blocked from the api. When we ran the setup manually on the server, the upgrade finished successfully.

Hi,

You don’t need to hit every point version of an LTS. Just one.

 
Ann