Sonar.login replaced with sonar.token not working

Hello all,

We tried to replace sonar.login with sonar.token and is not working. We are receiving:

The token you provided doesn't have sufficient rights to check license.
0.792 06:33:02.256  Pre-processing failed. Exit code: 1

We are using community edition and we installed it via helm chart:

CHART               	APP VERSION
sonarqube-10.1.0+628	10.1.0

We already granted full access to the user where the token has been created.

Thank you,
-Ionut

Hi,

Welcome to the community!

You link this error to the switch from sonar.login to sonar.token. Does that mean that if you change the parameter name back - with exactly the same token value - you don’t get the error?

 
Ann

Hello,

The value is different and even the type of string is different for sonar.login and sonar.token. Tbh, I did not tried that and I don’t believe that will work.

I know that sonar.login is deprecated, but how we can move forward to use sonar.token instead of sonar.login? Is there documentation or could you please help me by sending one?

Thank you,
-Ionut

Hi Ionut,

Can you try passing the old value as the argument to sonar.login? I’m pretty sure it’s going to work.

 
Ann